Commit 0de8d985 authored by encounter's avatar encounter

Require Blender 2.81+

parent 91d9e56e
......@@ -57,9 +57,9 @@ class PathHasher:
read_str = readpipestr()
return int(read_str[0:8], 16)
# Ensure Blender 2.8 is being used
if bpy.app.version < (2, 80, 0):
writepipestr(b'NOT280')
# Ensure Blender 2.81 is being used
if bpy.app.version < (2, 81, 0):
writepipestr(b'NOT281')
_quitblender()
# If there's a third argument, use it as the .zip path containing the addon
......
......@@ -527,9 +527,9 @@ Connection::Connection(int verbosityLevel) {
else
BlenderLog.report(logvisor::Fatal, fmt(_SYS_STR("Unable to find blender at '{}'")), DEFAULT_BLENDER_BIN);
#endif
} else if (lineStr == "NOT280") {
} else if (lineStr == "NOT281") {
_closePipe();
BlenderLog.report(logvisor::Fatal, fmt(_SYS_STR("Installed blender version must be >= 2.80")));
BlenderLog.report(logvisor::Fatal, fmt(_SYS_STR("Installed blender version must be >= 2.81")));
} else if (lineStr == "NOADDON") {
_closePipe();
if (blenderAddonPath != _SYS_STR("SKIPINSTALL"))
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment